Website of Daniel A. Mayer

Missing Libraries for Skype on Ubuntu 12.04 LTS (Precise Pangolin)

After upgrading my workstation to the 64-bit version of  Ubuntu 12.04 (Precise Pangolin) (from 11.10) I realized that Skype did not start anymore. The problem was simply a missing 32-bit library and the problem is quickly fixed as follows.

Running Skype from the command line revealed the missing library:

1
2
$ skype
skype: error while loading shared libraries: libXv.so.1: cannot open shared object file: No such file or directory

Using ldd to check which libraries are dynamically linked confirmed that libXv is the only prerequisite  that is missing, i.e., that is listed as "not found":

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
$ ldd /usr/bin/skype
    linux-gate.so.1 =>  (0xf7796000)
    libasound.so.2 => /usr/lib/i386-linux-gnu/libasound.so.2 (0xf767d000)
    libXv.so.1 => not found
    libXss.so.1 => /usr/lib/i386-linux-gnu/libXss.so.1 (0xf7678000)
    librt.so.1 => /lib/i386-linux-gnu/librt.so.1 (0xf766f000)
    libQtDBus.so.4 => /usr/lib/i386-linux-gnu/libQtDBus.so.4 (0xf75ef000)
    libQtGui.so.4 => /usr/lib/i386-linux-gnu/libQtGui.so.4 (0xf6b1e000)
    libQtNetwork.so.4 => /usr/lib/i386-linux-gnu/libQtNetwork.so.4 (0xf69d2000)
    libQtCore.so.4 => /usr/lib/i386-linux-gnu/libQtCore.so.4 (0xf66f4000)
    libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0xf66d9000)
    libstdc++.so.6 => /usr/lib/i386-linux-gnu/libstdc++.so.6 (0xf65f4000)
    libm.so.6 => /lib/i386-linux-gnu/libm.so.6 (0xf65c8000)
    libgcc_s.so.1 => /lib/i386-linux-gnu/libgcc_s.so.1 (0xf65aa000)
    libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf6405000)
    libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xf6400000)
    libX11.so.6 => /usr/lib/i386-linux-gnu/libX11.so.6 (0xf62cc000)
    libXext.so.6 => /usr/lib/i386-linux-gnu/libXext.so.6 (0xf62ba000)
    libQtXml.so.4 => /usr/lib/i386-linux-gnu/libQtXml.so.4 (0xf627a000)
    libdbus-1.so.3 => /lib/i386-linux-gnu/libdbus-1.so.3 (0xf6230000)
    libfontconfig.so.1 => /usr/lib/i386-linux-gnu/libfontconfig.so.1 (0xf61fc000)
    libaudio.so.2 => /usr/lib/i386-linux-gnu/libaudio.so.2 (0xf61e3000)
    libglib-2.0.so.0 => /lib/i386-linux-gnu/libglib-2.0.so.0 (0xf60ea000)
    libpng12.so.0 => /lib/i386-linux-gnu/libpng12.so.0 (0xf60c0000)
    libz.so.1 => /lib/i386-linux-gnu/libz.so.1 (0xf60a9000)
    libfreetype.so.6 => /usr/lib/i386-linux-gnu/libfreetype.so.6 (0xf600f000)
    libgobject-2.0.so.0 => /usr/lib/i386-linux-gnu/libgobject-2.0.so.0 (0xf5fbe000)
    libSM.so.6 => /usr/lib/i386-linux-gnu/libSM.so.6 (0xf5fb5000)
    libICE.so.6 => /usr/lib/i386-linux-gnu/libICE.so.6 (0xf5f9b000)
    libXi.so.6 => /usr/lib/i386-linux-gnu/libXi.so.6 (0xf5f8a000)
    libXrender.so.1 => /usr/lib/i386-linux-gnu/libXrender.so.1 (0xf5f80000)
    /lib/ld-linux.so.2 (0xf7797000)
    libxcb.so.1 => /usr/lib/i386-linux-gnu/libxcb.so.1 (0xf5f5f000)
    libexpat.so.1 => /lib/i386-linux-gnu/libexpat.so.1 (0xf5f35000)
    libXt.so.6 => /usr/lib/i386-linux-gnu/libXt.so.6 (0xf5ed8000)
    libXau.so.6 => /usr/lib/i386-linux-gnu/libXau.so.6 (0xf5ed4000)
    libpcre.so.3 => /lib/i386-linux-gnu/libpcre.so.3 (0xf5e98000)
    libffi.so.6 => /usr/lib/i386-linux-gnu/libffi.so.6 (0xf5e91000)
    libuuid.so.1 => /lib/i386-linux-gnu/libuuid.so.1 (0xf5e8b000)
    libXdmcp.so.6 => /usr/lib/i386-linux-gnu/libXdmcp.so.6 (0xf5e83000)

The 32-bit version of the library can easily be installed using:

1
sudo apt-get install libxv1:i386

You may need to install other 32-bit libraries if ldd lists more than one as "not found". Hope this helps somebody.

Comments